Current discussions | Archive 1 (2014-2019)

Autoundo script

Hello. Is it possible for you to add another "prepend delete|spam" to your undo script? Minorax (talk) 03:46, 26 February 2020 (UTC)

@Minorax:   Done --WhitePhosphorus (talk) 11:53, 26 February 2020 (UTC)
Thank you :) Minorax (talk) 13:10, 26 February 2020 (UTC)

User:WhitePhosphorus/all-in-one

Hi man, sometimes all-in-one does not autopopulate the username field. I find this is most often when the wiki is non-English or uses arabic script. Any ideas on how this can be fixed? Love this tool! Its my most used - I hit every spambot with it. ~riley (talk) 22:46, 18 April 2020 (UTC)

@~riley: Sorry I cannot reproduce this, for example this guy on arwiki. If you are able to reproduce this please provide the contribution link. Auto completion will only work on Special:Contributions/Example or Special:Logs/Example etc. pages and the script uses the username provided by mediawiki (search "wgRelevantUserName") so if this is really an issue maybe we shall go to phabricator. --WhitePhosphorus (talk) 03:26, 19 April 2020 (UTC)
I will come back when I can reproduce it! :) On a related note, packages break when using inf. I experienced this previously and Vermont did today; see Special:Diff/19995059. ~riley (talk) 04:25, 19 April 2020 (UTC)
Figured out the problem - it is when I am clicking all-in-one on user pages. I noticed it was only happening for spambots and thats mostly because I was opening up spam in userspace. Can auto completion support be added for userspace? ~riley (talk) 04:32, 19 April 2020 (UTC)
@~riley: Done. Also works on user talk page though rarely needed I guess. --WhitePhosphorus (talk) 04:42, 19 April 2020 (UTC)
Fantastic! Any idea whats going on with inf? ~riley (talk) 04:55, 19 April 2020 (UTC)

Your user page

Sorry for Hamish went stupid again on your user page. --Hamish 16:49, 26 April 2020 (UTC)

Over-qualified CSS selectors

My apologies that this message is just available in English.

Over-qualified CSS selectors of portals in Wikimedia skins have been changed. div#p-personal, div#p-navigation, div#p-interaction, div#p-tb, div#p-lang, div#p-namespaces or div#p-variants are now all removed of the div qualifier, as in for example it is #p-personal, #p-navigation …. This is so the skins can use HTML5 elements. Your gadgets or user styles seem to use them and you will have to update them. You can read more in phab:T252467. Johan (WMF) through MediaWiki message delivery (talk) 12:27, 8 June 2020 (UTC)